32da9861d5
Any other cgit configuration in depot would need this script wrapper as well. Change-Id: Ifa04e1c9de9c925eb3f60c5d3854221ae02ef06c Reviewed-on: https://cl.tvl.fyi/c/depot/+/5206 Tested-by: BuildkiteCI Reviewed-by: tazjin <tazjin@tvl.su> Autosubmit: sterni <sternenseemann@systemli.org>
72 lines
2 KiB
Nix
72 lines
2 KiB
Nix
# This derivation configures a 'cgit' instance to serve repositories
|
|
# from a different source.
|
|
{ depot, pkgs, ... }:
|
|
|
|
let
|
|
inherit (pkgs)
|
|
mime-types
|
|
thttpd
|
|
writeShellScriptBin
|
|
writeText
|
|
;
|
|
|
|
cgitConfig = writeText "cgitrc" ''
|
|
# Global configuration
|
|
virtual-root=/
|
|
enable-http-clone=0
|
|
readme=:README.md
|
|
about-filter=${depot.tools.cheddar.about-filter}/bin/cheddar-about
|
|
source-filter=${depot.tools.cheddar}/bin/cheddar
|
|
enable-log-filecount=1
|
|
enable-log-linecount=1
|
|
enable-follow-links=1
|
|
enable-blame=1
|
|
mimetype-file=${mime-types}/etc/mime.types
|
|
logo=https://static.tvl.fyi/${depot.web.static.drvHash}/logo-animated.svg
|
|
|
|
# Repository configuration
|
|
repo.url=depot
|
|
repo.path=/var/lib/gerrit/git/depot.git/
|
|
repo.desc=monorepo for the virus lounge
|
|
repo.owner=The Virus Lounge
|
|
repo.clone-url=https://code.tvl.fyi/depot.git
|
|
'';
|
|
|
|
thttpdConfig = writeText "thttpd.conf" ''
|
|
port=2448
|
|
dir=${depot.third_party.cgit}/cgit
|
|
nochroot
|
|
novhost
|
|
cgipat=**.cgi
|
|
'';
|
|
|
|
# Patched version of thttpd that serves cgit.cgi as the index and
|
|
# sets the environment variable for pointing cgit at the correct
|
|
# configuration.
|
|
#
|
|
# Things are done this way because recompilation of thttpd is much
|
|
# faster than cgit and I don't want to wait long when iterating on
|
|
# config.
|
|
thttpdConfigPatch = writeText "thttpd_cgit_conf.patch" ''
|
|
diff --git a/libhttpd.c b/libhttpd.c
|
|
index c6b1622..eef4b73 100644
|
|
--- a/libhttpd.c
|
|
+++ b/libhttpd.c
|
|
@@ -3055,4 +3055,6 @@ make_envp( httpd_conn* hc )
|
|
|
|
envn = 0;
|
|
+ // force cgit to load the correct configuration
|
|
+ envp[envn++] = "CGIT_CONFIG=${cgitConfig}";
|
|
envp[envn++] = build_env( "PATH=%s", CGI_PATH );
|
|
#ifdef CGI_LD_LIBRARY_PATH
|
|
'';
|
|
thttpdCgit = thttpd.overrideAttrs (old: {
|
|
patches = [
|
|
./thttpd_cgi_idx.patch
|
|
thttpdConfigPatch
|
|
];
|
|
});
|
|
in
|
|
writeShellScriptBin "cgit-launch" ''
|
|
exec ${thttpdCgit}/bin/thttpd -D -C ${thttpdConfig}
|
|
''
|