tvl-depot/web/cgit-taz/default.nix
Vincent Ambo 473604f567 refactor: Move nixpkgs attribute to third_party.nixpkgs
Please read b/108 to make sense of this.

This gets rid of the explicit list of exposed packages from nixpkgs,
and instead makes the entire package set available at
`third_party.nixpkgs`.

To accommodate this, a LOT of things have to be very slightly shuffled
around. Some of this was done in already submitted CLs, but this
change is unfortunately still quite noisy.

Pay extra attention to:

* overlay-like functionality that was partially moved to actual
  overlays (partially as in, the minimum required to get a green
  build)

* modified uses of the package set path, esp. in NixOS systems

Special notes:

* xanthous has been disabled in CI because of issues with the Haskell
  overlay
* //third_party/nix has been disabled because of other unclear
  dependency issues

Both of these will be tackled in a followup CL.

Change-Id: I2f9c60a4d275fdb5209264be0addfd7e06c53118
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2910
Reviewed-by: glittershark <grfn@gws.fyi>
Reviewed-by: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
2021-04-10 21:18:55 +00:00

74 lines
2.1 KiB
Nix

# This derivation configures a 'cgit' instance to serve repositories
# from a different source.
{ depot, pkgs, ... }:
let
inherit (pkgs)
mime-types
thttpd
writeShellScriptBin
writeText
;
sourceFilter = writeShellScriptBin "cheddar-about" ''
exec ${depot.tools.cheddar}/bin/cheddar --about-filter $@
'';
cgitConfig = writeText "cgitrc" ''
# Global configuration
virtual-root=/
enable-http-clone=1
readme=:README.md
about-filter=${sourceFilter}/bin/cheddar-about
source-filter=${depot.tools.cheddar}/bin/cheddar
enable-log-filecount=1
enable-log-linecount=1
enable-follow-links=1
enable-blame=1
mimetype-file=${mime-types}/etc/mime.types
logo=/plain/fun/logo/depot-logo.png
# Repository configuration
repo.url=depot
repo.path=/var/lib/gerrit/git/depot.git/
repo.desc=monorepo for the virus lounge
repo.owner=tazjin <mail@tazj.in>
repo.clone-url=https://code.tvl.fyi
'';
thttpdConfig = writeText "thttpd.conf" ''
port=2448
dir=${depot.third_party.cgit}/cgit
nochroot
novhost
cgipat=**.cgi
'';
# Patched version of thttpd that serves cgit.cgi as the index and
# sets the environment variable for pointing cgit at the correct
# configuration.
#
# Things are done this way because recompilation of thttpd is much
# faster than cgit and I don't want to wait long when iterating on
# config.
thttpdConfigPatch = writeText "thttpd_cgit_conf.patch" ''
diff --git a/libhttpd.c b/libhttpd.c
index c6b1622..eef4b73 100644
--- a/libhttpd.c
+++ b/libhttpd.c
@@ -3055,4 +3055,6 @@ make_envp( httpd_conn* hc )
envn = 0;
+ // force cgit to load the correct configuration
+ envp[envn++] = "CGIT_CONFIG=${cgitConfig}";
envp[envn++] = build_env( "PATH=%s", CGI_PATH );
#ifdef CGI_LD_LIBRARY_PATH
'';
thttpdCgit = thttpd.overrideAttrs(old: {
patches = [
./thttpd_cgi_idx.patch
thttpdConfigPatch
];
});
in writeShellScriptBin "cgit-launch" ''
exec ${thttpdCgit}/bin/thttpd -D -C ${thttpdConfig}
''