tvl-depot/third_party/gerrit_plugins/oauth/default.nix
sterni 5daaaa2f0b chore(3p/sources): bump channels & overlays
* //3p/overlays/tvl: build nixos-option with latest Nix version (2.24)
  as is required now. It would be nice to avoid this somehow to prevent
  NixOS machines in depot having to carry around two versions of Nix.
  Maybe we can at least use a statically linked nixos-option?

* //3p/{gerrit,gerrit_plugins}: update deps hash

* //tvix/eval: adjust our nixVersion “user agent” so that it'll pass the
  new 2.3.17 minimum version nixpkgs prescribes (to check for zstd
  support when substituting from the binary cache).

Change-Id: I4eb715afdc3dbb857340839f08ce86612aa7f117
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12805
Reviewed-by: flokli <flokli@flokli.de>
Autosubmit: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
2024-11-18 14:01:20 +00:00

18 lines
565 B
Nix

{ depot, pkgs, ... }@args:
let
inherit (import ../builder.nix args) buildGerritBazelPlugin;
in
buildGerritBazelPlugin rec {
name = "oauth";
version = "982316";
src = pkgs.fetchgit {
url = "https://gerrit.googlesource.com/plugins/oauth";
rev = "98231604d60788bb43490f1a301d792817ac8008";
hash = "sha256-AuVO1Yys8BYqGHZI/adszCUg0JM2v4Td4fe26LdOPLM=";
};
depsHash = "sha256:10py3vq9sfq5j4gjrlxff01vp346jbcygry06x4zc26xgnf4pa9r";
postOverlayPlugin = ''
cp "${src}/external_plugin_deps.bzl" "$out/plugins/external_plugin_deps.bzl"
'';
}