chore: Significantly restructure folder layout
This moves the various projects from "type-based" folders (such as "services" or "tools") into more appropriate semantic folders (such as "nix", "ops" or "web"). Deprecated projects (nixcon-demo & gotest) which only existed for testing/demonstration purposes have been removed. (Note: *all* builds are broken with this commit)
This commit is contained in:
parent
e52eed3cd4
commit
03bfe08e1d
110 changed files with 1 additions and 998 deletions
69
web/cgit-taz/default.nix
Normal file
69
web/cgit-taz/default.nix
Normal file
|
@ -0,0 +1,69 @@
|
|||
# This derivation configures a 'cgit' instance to serve repositories
|
||||
# from a different source.
|
||||
#
|
||||
# In the first round this will just serve my GitHub repositories until
|
||||
# I'm happy with the display.
|
||||
|
||||
{ pkgs, ... }:
|
||||
|
||||
with pkgs.third_party;
|
||||
|
||||
let
|
||||
# Patched version of cgit that builds repository URLs correctly
|
||||
# (since only one repository is served)
|
||||
monocgit = cgit.overrideAttrs(old: {
|
||||
patches = old.patches ++ [ ./cgit_depot_url.patch ];
|
||||
});
|
||||
|
||||
cgitConfig = writeText "cgitrc" ''
|
||||
# Global configuration
|
||||
virtual-root=/
|
||||
enable-http-clone=1
|
||||
readme=:README.md
|
||||
about-filter=${monocgit}/lib/cgit/filters/about-formatting.sh
|
||||
source-filter=${monocgit}/lib//cgit/filters/syntax-highlighting.py
|
||||
|
||||
# Repository configuration
|
||||
repo.url=depot
|
||||
repo.path=/git/depot/.git
|
||||
repo.desc=tazjin's personal monorepo
|
||||
repo.owner=tazjin <mail@tazj.in>
|
||||
repo.clone-url=https://git.tazj.in ssh://source.developers.google.com:2022/p/tazjins-infrastructure/r/depot
|
||||
repo.enable-remote-branches=1
|
||||
'';
|
||||
|
||||
thttpdConfig = writeText "thttpd.conf" ''
|
||||
port=8080
|
||||
dir=${monocgit}/cgit
|
||||
nochroot
|
||||
novhost
|
||||
logfile=/dev/stdout
|
||||
cgipat=**.cgi
|
||||
'';
|
||||
|
||||
# Patched version of thttpd that serves cgit.cgi as the index and
|
||||
# sets the environment variable for pointing cgit at the correct
|
||||
# configuration.
|
||||
#
|
||||
# Things are done this way because recompilation of thttpd is much
|
||||
# faster than cgit and I don't want to wait long when iterating on
|
||||
# config.
|
||||
thttpdConfigPatch = writeText "thttpd_cgit_conf.patch" ''
|
||||
diff --git a/libhttpd.c b/libhttpd.c
|
||||
index c6b1622..eef4b73 100644
|
||||
--- a/libhttpd.c
|
||||
+++ b/libhttpd.c
|
||||
@@ -3055,4 +3055,6 @@ make_envp( httpd_conn* hc )
|
||||
|
||||
envn = 0;
|
||||
+ // force cgit to load the correct configuration
|
||||
+ envp[envn++] = "CGIT_CONFIG=${cgitConfig}";
|
||||
envp[envn++] = build_env( "PATH=%s", CGI_PATH );
|
||||
#ifdef CGI_LD_LIBRARY_PATH
|
||||
'';
|
||||
thttpdCgit = thttpd.overrideAttrs(old: {
|
||||
patches = [ ./cgit_idx.patch thttpdConfigPatch ];
|
||||
});
|
||||
in writeShellScriptBin "cgit-launch" ''
|
||||
exec ${thttpdCgit}/bin/thttpd -D -C ${thttpdConfig}
|
||||
# ''
|
Loading…
Add table
Add a link
Reference in a new issue