nixos-anywhere-bare/config/programs.nix
2024-04-10 19:47:45 +02:00

37 lines
501 B
Nix

{
config,
pkgs,
lib,
...
}: {
environment.systemPackages = with pkgs; [
dhcpdump
dig
iftop
eza
git
htop
jq
lazygit
mosh
nmap
npins
ripgrep
screen
tcpdump
unzip
vim
wget
wireguard-tools
];
environment.shellAliases = {
l = "eza -lah --git --git-repos-no-status";
};
programs.mosh.enable = !(builtins.elem config.networking.hostName []);
programs.mtr.enable = true;
programs.vim.defaultEditor = true;
}