kat-pkgs/python-pkgs/django-impersonate.nix
2024-10-25 18:09:28 +02:00

35 lines
792 B
Nix

{
lib,
buildPythonPackage,
fetchFromGitHub,
setuptools,
wheel,
}:
buildPythonPackage rec {
pname = "django-impersonate";
version = "0.9.3";
pyproject = true;
src = fetchFromGitHub {
owner = "BetterWorks";
repo = "django-impersonate";
rev = version;
hash = "sha256-IELpNA5G67FepRKxNEOGRqzb1QwfrzAJzTCrYtQsM34=";
};
build-system = [
setuptools
wheel
];
pythonImportsCheck = [ "impersonate" ];
meta = {
description = "Fork of https://bitbucket.org/petersanchez/django-impersonate";
homepage = "https://github.com/BetterWorks/django-impersonate.git";
changelog = "https://github.com/BetterWorks/django-impersonate/blob/${src.rev}/CHANGELOG";
license = lib.licenses.bsd3;
maintainers = with lib.maintainers; [ ];
};
}