36 lines
715 B
Nix
36 lines
715 B
Nix
{
|
|
lib,
|
|
buildPythonPackage,
|
|
fetchFromGitHub,
|
|
setuptools,
|
|
wheel,
|
|
}:
|
|
|
|
buildPythonPackage rec {
|
|
pname = "django-hcaptcha";
|
|
version = "0.2.0";
|
|
pyproject = true;
|
|
|
|
src = fetchFromGitHub {
|
|
owner = "AndrejZbin";
|
|
repo = "django-hcaptcha";
|
|
rev = "v${version}";
|
|
hash = "sha256-g6I/CKxaRWuXLVhuAe1auC3+gHwcyYhoc/px+OfP4o8=";
|
|
};
|
|
|
|
build-system = [
|
|
setuptools
|
|
wheel
|
|
];
|
|
|
|
pythonImportsCheck = [
|
|
"hcaptcha"
|
|
];
|
|
|
|
meta = {
|
|
description = "Django hCaptcha provides a simple way to protect your django forms using hCaptcha";
|
|
homepage = "https://github.com/AndrejZbin/django-hcaptcha.git";
|
|
license = lib.licenses.bsd3;
|
|
maintainers = with lib.maintainers; [ ];
|
|
};
|
|
}
|