arcade/flake.nix

36 lines
1 KiB
Nix

{
description = "Minimal NixOS installation media";
inputs = {
nixpkgs.url = "nixpkgs/23.11";
home-manager.url = "github:nix-community/home-manager/release-23.11";
home-manager.inputs.nixpkgs.follows = "nixpkgs";
};
outputs = { self, nixpkgs, home-manager, ... }@inputs:
let
username = "arcade";
userhome = "/home/${username}";
in {
nixosConfigurations = {
vm = nixpkgs.lib.nixosSystem {
system = "x86_64-linux";
specialArgs = { inherit inputs username userhome; };
modules = [
home-manager.nixosModules.home-manager
{
home-manager.users.arcade = { ... }: {
home.username = username;
home.homeDirectory = userhome;
home.stateVersion = "23.11";
home.file."roms".source = ./emulationstation/roms;
};
}
./configuration.nix
./emulationstation/configuration-files.nix
"${nixpkgs}/nixos/modules/profiles/qemu-guest.nix"
];
};
};
};
}