37 lines
1.1 KiB
Nix
37 lines
1.1 KiB
Nix
({ config, lib, pkgs, home-manager, username, userhome, ... }: {
|
|
system.stateVersion = "23.11";
|
|
|
|
environment.systemPackages = [
|
|
pkgs.xorg.xorgserver
|
|
pkgs.xorg.xinit
|
|
pkgs.xorg.xf86inputevdev
|
|
pkgs.xorg.xf86inputsynaptics
|
|
pkgs.xorg.xf86inputlibinput
|
|
pkgs.xorg.xf86videointel
|
|
pkgs.xorg.xf86videoati
|
|
pkgs.xorg.xf86videonouveau
|
|
pkgs.emulationstation
|
|
pkgs.home-manager
|
|
];
|
|
|
|
users.users."${username}" = {
|
|
isNormalUser = true;
|
|
home = userhome;
|
|
extraGroups = [ "wheel" ];
|
|
initialHashedPassword = "$y$j9T$mZVJ.MyA3PnxIzrUr4NbO.$wp6VqO0WphwynzPhw4Y3X57VcAaFla3sO9gTdV25xq8";
|
|
};
|
|
programs.bash.loginShellInit =
|
|
"startx ${pkgs.emulationstation}/bin/emulationstation";
|
|
|
|
hardware.opengl.enable = true;
|
|
hardware.opengl.driSupport = true;
|
|
services.xserver.enable = true;
|
|
services.xserver.displayManager.startx.enable = true;
|
|
services.xserver.libinput.enable = true;
|
|
services.getty.autologinUser = "arcade";
|
|
|
|
boot.loader.systemd-boot.enable = true;
|
|
|
|
console.keyMap = "fr";
|
|
services.openssh = lib.mkForce { enable = false; };
|
|
})
|