1
0
Fork 0
forked from DGNum/landing
landing/landing.nix
2024-10-10 23:33:32 +02:00

51 lines
2.1 KiB
Nix

{
lib,
writeText,
logo,
description,
links,
}:
writeText "index.html" ''
<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8" />
<meta http-equiv="content-language" content="en" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta http-equiv="X-UA-Compatible" content="ie=edge" />
<title>Liens DGNum</title>
<meta name="title" content="Liens DGNum" />
<link type="text/css" rel="stylesheet" href="main.css"/>
</head>
<body class="bg-neutral m-auto flex h-screen max-w-7xl flex-col px-6 text-lg leading-7 text-neutral-900 sm:px-14 md:px-24 lg:px-32 dark:bg-neutral-800 dark:text-white">
<main class="flex-grow">
<article class="mt-10 flex h-full flex-col items-center justify-center text-center">
<header class="mb-3 flex flex-col items-center">
<img class="mb-2 h-36 w-36 rounded-full" width="144" height="144" alt="Délégation Générale Numérique" src="img/${builtins.baseNameOf logo}"/>
<h1 class="text-4xl font-extrabold dark:text-white">Délégation Générale Numérique</h1>
<h2 class="max-w-lg mt-2 text-xl text-neutral-500 dark:text-neutral-400">${description}</h2>
</header>
<div class="mt-4 flex min-w-full flex-col flex-wrap sm:min-w-0">
${
lib.concatMapStrings (link: ''
<a class="link link-${
if builtins.hasAttr "linkClass" link then link.linkClass else "link"
} mb-3 min-w-full rounded py-2 text-lg sm:px-24" href="${link.target}">
<span class="mr-1">
<span class="icon relative inline-block align-text-bottom">${builtins.readFile link.svgFile}</span>
</span>
${link.text}
</a>
'') links
}
</div>
</article>
</main>
<footer class="py-10"></footer>
</body>
</html>
''