infrastructure/machines/compute01/_configuration.nix
Ryan Lahfa a4de5f4d31 feat(krz01): move ollama to compute01 via a reverse proxy
krz01 has no public web IP.

Signed-off-by: Ryan Lahfa <ryan@dgnum.eu>
2024-10-10 17:40:56 +02:00

46 lines
768 B
Nix

{ lib, ... }:
lib.extra.mkConfig {
# List of modules to enable
enabledModules = [
# INFO: This list needs to stay sorted alphabetically
"dgn-backups"
"dgn-chatops"
"dgn-web"
];
# List of services to enable
enabledServices = [
# INFO: This list needs to stay sorted alphabetically
"arkheon"
"dgsi"
"ds-fr"
"grafana"
"hedgedoc"
"kanidm"
"librenms"
"mastodon"
"nextcloud"
"ollama-proxy"
"outline"
"plausible"
"postgresql"
"rstudio-server"
"satosa"
"signal-irc-bridge"
"signald"
"stirling-pdf"
"takumi"
"telegraf"
"vaultwarden"
"zammad"
];
extraConfig = {
dgn-hardware.useZfs = true;
services.netbird.enable = true;
};
root = ./.;
}