stateless-uptime-kuma/uptime-kuma-api.nix
2024-12-08 00:13:56 +01:00

45 lines
1,001 B
Nix

{
lib,
buildPythonPackage,
fetchFromGitea,
setuptools,
wheel,
packaging,
python-socketio,
requests,
}:
buildPythonPackage rec {
pname = "uptime-kuma-api";
version = "2.0.0";
pyproject = true;
src = fetchFromGitea {
domain = "git.dgnum.eu";
owner = "Luj";
repo = "uptime-kuma-api";
rev = "782037348df18dd32c3904c812c289f3d2d79170";
hash = "sha256-YK4KMtKPlxqWwzB6lLyFqLvq1RCiUWrIILcVmuiirFw=";
};
nativeBuildInputs = [
setuptools
wheel
];
propagatedBuildInputs = [
packaging
python-socketio
requests
] ++ python-socketio.optional-dependencies.client;
pythonImportsCheck = [ "uptime_kuma_api" ];
meta = with lib; {
description = "A Python wrapper for the Uptime Kuma Socket.IO API";
homepage = "https://github.com/lucasheld/uptime-kuma-api";
changelog = "https://github.com/lucasheld/uptime-kuma-api/blob/${src.rev}/CHANGELOG.md";
license = licenses.mit;
maintainers = with maintainers; [ ];
};
}