infrastructure/machines/core-services-01/drone-runners.nix
Ryan Lahfa 6f5fdb0317 Headscale support (upgrade to latest nixpkgs) (#9)
This adds Headscale support.

It provides also an upgrade to Keycloak 18.0.0 (Quarkus distribution).
It upgrades NextCloud from 22 to 23.

Reviewed-on: https://git.rz.ens.wtf/Klub-RZ/infrastructure/pulls/9
Co-authored-by: Ryan Lahfa <raito@noreply.git.rz.ens.wtf>
Co-committed-by: Ryan Lahfa <raito@noreply.git.rz.ens.wtf>
2022-06-26 23:48:43 +02:00

18 lines
539 B
Nix

{ config, lib, ... }:
let
capacity = 10;
in
{
services.drone-exec-runner.nix01 = {
enable = true;
restartIfChanged = false; # Prevent from killing itself as it is a core machine.
env = [
"DRONE_RUNNER_CAPACITY=${toString capacity}"
"CLIENT_DRONE_RPC_HOST=127.0.0.1:${toString config.services.drone-server.port}"
"DRONE_RUNNER_LABELS=nix:true" # nix-ready machine.
];
envFile = config.age.secrets.droneKeyFile.path;
};
systemd.services."drone-exec-runner-nix01".after = [ "gitea.service" ];
}