hackens-org-configurations/hosts/hackens-org/test-webhook.nix
2022-04-03 01:27:30 +02:00

17 lines
351 B
Nix

{ config, pkgs, ... }:
{
services.webhooks = {
enable = true;
hostname = "test-webhook.${config.my.subZone}";
hooks = [
{
id = "testhook";
execute-command = pkgs.writeScript "echo.sh" ''
#!/bin/sh
echo "Bonjour"
'';
response-message = "Test hook sucess";
}
];
};
}