hackens-org-configurations/meta.nix
2024-06-11 14:41:57 +02:00

37 lines
805 B
Nix

let
sources = import ./npins;
agenix = sources.agenix + "/modules/age.nix";
djangonix = sources.djangonix + "/module.nix";
metadata = {
nodes = {
hackens-milieu = {
deployment = {
targetHost = null; #"milieu.cave.hackens.org";
#targetPort = 4243;
allowLocalDeployment = true;
tags = [ "desktop" ];
};
imports = [agenix];
};
rigel = {
deployment = {
targetHost = "10.1.1.1";
};
arch = "aarch64-linux";
};
hackens-org = {
deployment = {
targetHost = "10.10.10.1"; # todo make something with ens firewall
tags = [ "server" ];
targetPort = 22;
};
imports = [agenix djangonix];
};
};
};
in
metadata