42 lines
1.4 KiB
Nix
42 lines
1.4 KiB
Nix
{ ... }:
|
|
{
|
|
users = {
|
|
mutableUsers = false;
|
|
users = {
|
|
rlahfa = {
|
|
isNormalUser = true;
|
|
extraGroups = [ "wheel" ];
|
|
hashedPassword = "$6$y/I6nKCMYUku7$91vTR5kYz4nHyhbuA/j6kPsD8Vfo/Rg7ri6Ympftra9V6emOt/mPg0AScECtYjSIxretvfQ3sPUF1Ho0IWx381";
|
|
openssh.authorizedKeys.keyFiles = [ ../../pubkeys/raito.keys ];
|
|
};
|
|
gdoriathdohler = {
|
|
isNormalUser = true;
|
|
extraGroups = [ "wheel" ];
|
|
openssh.authorizedKeys.keyFiles = [ ../../pubkeys/gdd.keys ];
|
|
};
|
|
mdebray = {
|
|
isNormalUser = true;
|
|
extraGroups = [ "wheel" ];
|
|
hashedPassword = "$6$ujz06kXa4TgvPAbF$NaXkDuOUpf3.fBRh7JuygtS0V2U/Bz4N3DpbOznO.md44xEdlKwPH/pSbL9CQJBhI5kodaKZeSaoCyhzybBPA/";
|
|
openssh.authorizedKeys.keyFiles = [ ../../pubkeys/sinavir.keys ];
|
|
};
|
|
ecoppens = {
|
|
isNormalUser = true;
|
|
extraGroups = [ "wheel" ];
|
|
hashedPassword = "$2b$05$c7kIDOunRJvgncWq5pmbXupy/wzUzCvN3b/RHgl/BjlUw891wI.Oa";
|
|
openssh.authorizedKeys.keyFiles = [ ../../pubkeys/soyouzpanda.keys ];
|
|
};
|
|
hbarral = {
|
|
isNormalUser = true;
|
|
extraGroups = [ "wheel" ];
|
|
openssh.authorizedKeys.keyFiles = [ ../../pubkeys/backslash.keys ];
|
|
};
|
|
root.openssh.authorizedKeys.keyFiles = [
|
|
../../pubkeys/beigbeder.keys
|
|
../../pubkeys/sinavir.keys
|
|
../../pubkeys/soyouzpanda.keys
|
|
../../pubkeys/catvayor.keys
|
|
];
|
|
};
|
|
};
|
|
}
|