19 lines
349 B
Nix
19 lines
349 B
Nix
{ ... }:
|
|
{
|
|
# Enable the OpenSSH daemon.
|
|
services.openssh.enable = true;
|
|
services.openssh.settings.PasswordAuthentication = false;
|
|
services.openssh.ports = [
|
|
22
|
|
2222
|
|
];
|
|
|
|
# Open ports in the firewall. (In fact not needed)
|
|
networking.firewall.allowedTCPPorts = [
|
|
22
|
|
2222
|
|
];
|
|
|
|
# Mosh <3
|
|
programs.mosh.enable = true;
|
|
}
|