3d4e782929
because checkPhase is not executed when cross-compiling, and this package is always only cross-compiled
26 lines
480 B
Nix
26 lines
480 B
Nix
{
|
|
lua
|
|
, nellie
|
|
, writeFennel
|
|
, anoia
|
|
, fennel
|
|
, stdenv
|
|
, fennelrepl
|
|
, lualinux
|
|
}:
|
|
stdenv.mkDerivation {
|
|
name = "devout";
|
|
src = ./.;
|
|
nativeBuildInputs = [ fennelrepl ];
|
|
postBuild = ''
|
|
LUA_CPATH=${lualinux}/lib/lua/5.3/?.so\;$LUA_CPATH \
|
|
fennelrepl ./test.fnl
|
|
'';
|
|
installPhase = ''
|
|
mkdir -p $out/bin
|
|
cp -p ${writeFennel "devout" {
|
|
packages = [fennel anoia nellie lualinux];
|
|
mainFunction = "run";
|
|
} ./devout.fnl} $out/bin/devout
|
|
'';
|
|
}
|