664624a478
Signed-off-by: Raito Bezarius <masterancpp@gmail.com>
18 lines
327 B
Nix
18 lines
327 B
Nix
{
|
|
liminix
|
|
, lib
|
|
, jitterentropy-rngd
|
|
}:
|
|
{ }:
|
|
let
|
|
inherit (liminix.services) longrun;
|
|
name = "jitterentropy-rngd";
|
|
in
|
|
longrun {
|
|
# Does it need to be unique?
|
|
inherit name;
|
|
run = ''
|
|
mkdir -p /run/jitterentropy-rngd
|
|
${jitterentropy-rngd}/bin/jitterentropy-rngd -v -p /run/jitterentropy-rngd/${name}.pid
|
|
'';
|
|
}
|