13069415fd
Some checks failed
build liminix / build_vm_qemu_mips (pull_request) Failing after 27s
WLAN oper wait until the WLAN interface is ready. Signed-off-by: Raito Bezarius <masterancpp@gmail.com>
16 lines
256 B
Nix
16 lines
256 B
Nix
{
|
|
liminix
|
|
, ifwait
|
|
, lib
|
|
}:
|
|
{ interface } :
|
|
let
|
|
inherit (liminix.services) oneshot;
|
|
in oneshot {
|
|
name = "${interface.name}.wlan-oper";
|
|
up = ''
|
|
${ifwait}/bin/ifbridgeable -v $(output ${interface} ifname)
|
|
'';
|
|
|
|
dependencies = [ interface ];
|
|
}
|