1bd9af1e9d
Some checks failed
build liminix / build_vm_qemu_mips (push) Failing after 27s
Consider the scenario where you run DHCPv4 on the primary bridge interface. You have no real interface to "wait upon", so it's OK. Nonetheless, anything depending on successful completion of DHCPv4, e.g. adding a default route, will block `s6-rc -v2 up change default`. The way new interfaces are attached to the bridge is via `s6-rc -b -u change $attach-oneshot-service`, this introduce in turn a deadlock. At some point, DHCPv4 will timeout, unblocking the deadlock and attaching the members to the primary bridge interface, making it ready to send L2 broadcast packets for DHCP, unblocking DHCP in turn again. This is not satisfying because we really want to have a no-hiccups bring-up. To fix this, we proceed to multiple changes: - we remove `svc.ifwait.build` out of band `s6-rc -b -u $oneshot-attach` call, which is, by design, wrong here. - users can now depend on the members service to know when a bridge is fully operational (we could make it more granular and let them depend on the LAN member joining rather than WLAN, etc.) - users can also depend on the primary service being brought up rather than just being present, this is useful if you need to bring it up when it has AT LEAST one member to get link local address or MAC addresses (fixing DHCPv6 bring up as well because `ff02::1` is used there). One thing is not addressed yet, if you are running a WLAN service using RADIUS attached to the bridge, at bring up time, it will try to reach out the external RADIUS server and *fail*. To solve this, granular dependency on the DHCPv4 once LAN is joined. Then the hostapd can wait on defaultroute4 completion so that connectivity is available to reach RADIUS server. It can join the bridge later on without any hiccup as well. This is left as a TODO as hostapd can survive RADIUS authentication failure and retry later. Signed-off-by: Raito Bezarius <masterancpp@gmail.com>
26 lines
673 B
Nix
26 lines
673 B
Nix
{
|
|
liminix
|
|
, ifwait
|
|
, lib
|
|
}:
|
|
{ ifname, macAddressFromInterface ? null } :
|
|
let
|
|
inherit (liminix.services) bundle oneshot;
|
|
inherit (lib) mkOption types optional;
|
|
in oneshot rec {
|
|
name = "${ifname}.link";
|
|
up = ''
|
|
${if macAddressFromInterface == null then
|
|
"ip link add name ${ifname} type bridge"
|
|
else
|
|
"ip link add name ${ifname} address $(output ${macAddressFromInterface} ether) type bridge"}
|
|
|
|
(in_outputs ${name}
|
|
echo ${ifname} > ifname
|
|
cat /sys/class/net/${ifname}/address > ether
|
|
)
|
|
'';
|
|
down = "ip link delete ${ifname}";
|
|
|
|
dependencies = optional (macAddressFromInterface != null) macAddressFromInterface;
|
|
}
|