lab-infra/meta/nodes.nix
sinavir 3915b492c4
Some checks failed
Check meta / check_meta (push) Failing after 19s
lint / check (push) Successful in 31s
build configuration / build_krz01 (push) Successful in 1m24s
feat(labcore01): init
Lab's core infra vm, doing only dns64 for now.
2024-11-07 01:10:24 +01:00

47 lines
1.1 KiB
Nix

###
# File specifying all the deployement options for the nodes administrated by the dgnum.
#
# Node metadata template is:
#
# NODE_NAME = {
# adminGroups = []; # List of groups that have root access
# admins = []; # List of individuals that have root access
# deployment = {}; # Colmena deployment options
# nixpkgs = "unstable" or "22.11"; # nixpkgs version
# }
/*
Liste des différents sites :
- rat01 -> VM du NPSPI
- pav01 -> Salle serveur sous le pavillon Pasteur
- oik01 -> Local DGNum Jourdan
- hyp01 -> Salle serveur Hypnos 1
- luj01 -> VM de Luj
*/
{
krz01 = {
site = "pav01";
hashedPassword = "$y$j9T$eNZQgDN.J5y7KTG2hXgat1$J1i5tjx5dnSZu.C9B7swXi5zMFIkUnmRrnmyLHFAt8/";
stateVersion = "24.05";
nixpkgs = "unstable";
};
labcore01 = {
site = "pav01";
hashedPassword = "$y$j9T$aFhOWa05W7VKeKt3Nc.nA1$uBOvG4wf7/yWjwOxO8NLf9ipCsAkS1.5cD2EJpLx57A";
stateVersion = "24.05";
nixpkgs = "24.05";
};
router02 = {
site = "pav01";
hashedPassword = "$y$j9T$aFhOWa05W7VKeKt3Nc.nA1$uBOvG4wf7/yWjwOxO8NLf9ipCsAkS1.5cD2EJpLx57A";
stateVersion = "24.05";
nixpkgs = "unstable";
};
}