lab-infra/machines/dns01/nsd.nix
Constantin Gierczak--Galle 225ced72c2
Some checks failed
Check meta / check_meta (push) Failing after 19s
lint / check (push) Successful in 23s
build configuration / build_krz01 (push) Failing after 1m21s
feat(dns01): init
Reviewed-on: #5
Co-authored-by: Constantin Gierczak--Galle <git.cst1@mailbox.org>
Co-committed-by: Constantin Gierczak--Galle <git.cst1@mailbox.org>
2024-11-22 21:32:35 +01:00

22 lines
398 B
Nix

{ sources, ... }:
let
dns = import sources.dns-nix { };
in
{
services.nsd = {
enable = true;
zones = {
"beta.dgnum.eu" = {
# provideXFR = [ ... ];
# notify = [ ... ];
data = dns.lib.toString "beta.dgnum.eu" (import ./beta.dgnum.eu.nix { inherit dns; });
};
};
};
networking = {
firewall = {
allowedUDPPorts = [ 53 ];
};
};
}