3085d9e3a8
All checks were successful
Build all the nodes / ap01 (push) Successful in 1m14s
Build all the nodes / bridge01 (push) Successful in 1m55s
Build all the nodes / geo01 (push) Successful in 1m57s
Build all the nodes / geo02 (push) Successful in 1m59s
Build all the nodes / compute01 (push) Successful in 2m29s
Build all the nodes / netcore02 (push) Successful in 32s
Build all the nodes / hypervisor01 (push) Successful in 1m30s
Build all the nodes / hypervisor02 (push) Successful in 1m34s
Build all the nodes / hypervisor03 (push) Successful in 1m36s
Build all the nodes / vault01 (push) Successful in 1m56s
Build all the nodes / rescue01 (push) Successful in 2m10s
Build all the nodes / storage01 (push) Successful in 2m10s
Build all the nodes / web02 (push) Successful in 1m42s
Run pre-commit on all files / pre-commit (push) Successful in 41s
Build all the nodes / web01 (push) Successful in 2m15s
Build all the nodes / web03 (push) Successful in 1m49s
65 lines
1.3 KiB
Nix
65 lines
1.3 KiB
Nix
# SPDX-FileCopyrightText: 2024 Tom Hubrecht <tom.hubrecht@dgnum.eu>
|
|
#
|
|
# SPDX-License-Identifier: EUPL-1.2
|
|
|
|
{
|
|
pkgs,
|
|
sources,
|
|
config,
|
|
...
|
|
}:
|
|
|
|
let
|
|
nix-pkgs = import sources.nix-pkgs { inherit pkgs; };
|
|
in
|
|
|
|
{
|
|
services.django-apps.sites.ernestophone = {
|
|
source = "https://git.dgnum.eu/DGNum/ernestophone.ens.fr";
|
|
branch = "update";
|
|
domain = "ernestophone.ens.fr";
|
|
|
|
nginx = {
|
|
enableACME = true;
|
|
forceSSL = true;
|
|
locations = {
|
|
"/media/trombonoscope/".root = "/run/django-apps/ernestophone/";
|
|
};
|
|
};
|
|
|
|
serveMedia = false;
|
|
|
|
webHookSecret = config.age.secrets."webhook-ernestophone_token".path;
|
|
|
|
python = pkgs.python3.override {
|
|
packageOverrides = _: _: {
|
|
inherit (nix-pkgs)
|
|
django-avatar
|
|
django-cas-ng
|
|
django-solo
|
|
loadcredential
|
|
;
|
|
};
|
|
};
|
|
|
|
dependencies = ps: [
|
|
ps.django
|
|
ps.django-avatar
|
|
ps.django-colorful
|
|
ps.gunicorn
|
|
ps.pillow
|
|
ps.loadcredential
|
|
];
|
|
|
|
application.module = "Ernestophone";
|
|
|
|
credentials = {
|
|
SECRET_KEY = config.age.secrets."dj_ernestophone-secret_key_file".path;
|
|
};
|
|
|
|
environment = {
|
|
DJANGO_SETTINGS_MODULE = "Ernestophone.settings";
|
|
ERNESTOPHONE_ALLOWED_HOSTS = [ "ernestophone.ens.fr" ];
|
|
};
|
|
};
|
|
}
|