infrastructure/machines/nixos/web03/django-apps/gestiojeux.nix
Tom Hubrecht 80ede4b1f6
All checks were successful
Build all the nodes / netcore02 (push) Successful in 21s
Build the shell / build-shell (push) Successful in 24s
Build all the nodes / netaccess01 (push) Successful in 28s
Build all the nodes / netcore01 (push) Successful in 28s
Build all the nodes / ap01 (push) Successful in 33s
Run pre-commit on all files / pre-commit (push) Successful in 25s
Build all the nodes / build01 (push) Successful in 1m41s
Build all the nodes / geo01 (push) Successful in 1m46s
Build all the nodes / storage01 (push) Successful in 1m52s
Build all the nodes / hypervisor01 (push) Successful in 2m7s
Build all the nodes / geo02 (push) Successful in 2m14s
Build all the nodes / hypervisor03 (push) Successful in 2m23s
Build all the nodes / bridge01 (push) Successful in 2m38s
Build all the nodes / tower01 (push) Successful in 2m38s
Build all the nodes / rescue01 (push) Successful in 2m43s
Build all the nodes / web03 (push) Successful in 2m42s
Build all the nodes / vault01 (push) Successful in 2m42s
Build all the nodes / hypervisor02 (push) Successful in 2m43s
Build all the nodes / web02 (push) Successful in 2m49s
Build all the nodes / web01 (push) Successful in 3m13s
Build all the nodes / compute01 (push) Successful in 3m20s
feat(web03): Do the migration
2025-02-24 15:33:42 +01:00

68 lines
1.5 KiB
Nix

# SPDX-FileCopyrightText: 2024 Tom Hubrecht <tom.hubrecht@dgnum.eu>
#
# SPDX-License-Identifier: EUPL-1.2
{ config, ... }:
{
services.django-apps.sites.gestiojeux = {
source = "https://git.dgnum.eu/DGNum/gestiojeux";
branch = "production";
domain = "jeux.cof.ens.fr";
nginx = {
enableACME = true;
forceSSL = true;
};
webHookSecret = config.age.secrets."webhook-gestiojeux_token".path;
application = {
type = "wsgi";
module = "gestiojeux";
};
overlays.nix-pkgs = [
"django-autoslug"
"django-cas-ng"
"loadcredential"
"markdown-icons"
# Dependencies
"python-cas"
];
django = ps: ps.django_4;
dependencies = ps: [
ps.django-autoslug
ps.loadcredential
ps.django-cas-ng
ps.django-cleanup
ps.django-haystack
ps.django-markdownx
ps.django-tables2
ps.pillow
ps.psycopg2
ps.whoosh
ps.markdown-icons
# Django haystack is drunk
ps.setuptools
];
staticDirectory = "source/public/static";
mediaDirectory = "source/public/media";
credentials = {
SECRET_KEY = config.age.secrets."dj_gestiojeux-secret_key_file".path;
};
environment = {
GESTIOJEUX_EMAIL_HOST_USER = "web-services@infra.dgnum.eu";
GESTIOJEUX_DEFAULT_FROM_EMAIL = "Kadenios <web-services@infra.dgnum.eu>";
GESTIOJEUX_SERVER_EMAIL = "webapps@infra.dgnum.eu";
GESTIOJEUX_DB_NAME = "dj-gestiojeux";
GESTIOJEUX_DB_USER = "dj-gestiojeux";
};
};
}