Tom Hubrecht
bf06d2573b
All checks were successful
Check workflows / check_workflows (push) Successful in 23s
Build all the nodes / bridge01 (push) Successful in 1m7s
Build all the nodes / geo02 (push) Successful in 1m6s
Build all the nodes / geo01 (push) Successful in 1m8s
Build all the nodes / rescue01 (push) Successful in 1m13s
Build all the nodes / compute01 (push) Successful in 1m29s
Build all the nodes / storage01 (push) Successful in 1m9s
Run pre-commit on all files / check (push) Successful in 24s
Build all the nodes / vault01 (push) Successful in 1m13s
Build all the nodes / web02 (push) Successful in 1m12s
Build all the nodes / web03 (push) Successful in 1m17s
Build all the nodes / web01 (push) Successful in 1m49s
31 lines
625 B
Nix
31 lines
625 B
Nix
{
|
|
name = "Check meta";
|
|
on = {
|
|
pull_request.branches = [ "main" ];
|
|
push.paths = [ "meta/*" ];
|
|
};
|
|
|
|
jobs = {
|
|
check_meta = {
|
|
runs-on = "nix";
|
|
steps = [
|
|
{ uses = "actions/checkout@v3"; }
|
|
{
|
|
name = "Check the validity of meta options";
|
|
run = "nix-build meta/verify.nix -A meta";
|
|
}
|
|
];
|
|
};
|
|
|
|
check_dns = {
|
|
runs-on = "nix";
|
|
steps = [
|
|
{ uses = "actions/checkout@v3"; }
|
|
{
|
|
name = "Check the validity of the DNS configuration";
|
|
run = "nix-build meta/verify.nix -A dns";
|
|
}
|
|
];
|
|
};
|
|
};
|
|
}
|