infrastructure/scripts/default.nix
Tom Hubrecht 7bdc70632c
All checks were successful
build configuration / build_and_cache_geo01 (push) Successful in 1m13s
build configuration / build_and_cache_geo02 (push) Successful in 1m17s
build configuration / build_and_cache_rescue01 (push) Successful in 1m26s
build configuration / build_and_cache_storage01 (push) Successful in 1m29s
build configuration / build_and_cache_compute01 (push) Successful in 1m37s
lint / check (push) Successful in 24s
build configuration / build_and_cache_krz01 (push) Successful in 2m13s
build configuration / build_and_cache_vault01 (push) Successful in 1m17s
build configuration / build_and_cache_bridge01 (push) Successful in 1m3s
build configuration / build_and_cache_web02 (push) Successful in 1m11s
build configuration / build_and_cache_web01 (push) Successful in 1m41s
chore(scripts): Cleanup of old caching script
2024-10-10 01:04:16 +02:00

39 lines
569 B
Nix

{ pkgs, ... }:
let
substitutions = {
inherit (pkgs)
bash
colmena
coreutils
nvd
git
jq
;
};
mkShellScript =
name:
(pkgs.substituteAll (
{
inherit name;
src = ./. + "/${name}.sh";
dir = "/bin/";
isExecutable = true;
checkPhase = ''
${pkgs.stdenv.shellDryRun} "$target"
'';
}
// substitutions
));
scripts = [
"cache-node"
"check-deployment"
"launch-vm"
"list-nodes"
];
in
builtins.map mkShellScript scripts