c0435e694d
All checks were successful
build configuration / build_and_cache_web02 (push) Successful in 1m9s
lint / check (push) Successful in 23s
build configuration / build_and_cache_web03 (push) Successful in 1m1s
build configuration / build_and_cache_bridge01 (push) Successful in 1m2s
Check meta / check_dns (push) Successful in 19s
Check meta / check_meta (push) Successful in 19s
build configuration / build_and_cache_rescue01 (push) Successful in 1m17s
build configuration / build_and_cache_geo01 (push) Successful in 1m1s
build configuration / build_and_cache_storage01 (push) Successful in 1m21s
build configuration / build_and_cache_geo02 (push) Successful in 1m2s
build configuration / build_and_cache_vault01 (push) Successful in 1m23s
build configuration / build_and_cache_web01 (push) Successful in 1m42s
build configuration / build_and_cache_compute01 (push) Successful in 1m37s
25 lines
448 B
Nix
25 lines
448 B
Nix
{ config, lib, ... }:
|
|
|
|
let
|
|
inherit (lib) mkEnableOption mkIf;
|
|
|
|
cfg = config.dgn-records;
|
|
in
|
|
|
|
{
|
|
options.dgn-records.enable = mkEnableOption "Arkheon deployment recording." // {
|
|
default = true;
|
|
};
|
|
|
|
config = mkIf cfg.enable {
|
|
services.arkheon.record = {
|
|
enable = true;
|
|
|
|
tokenFile = config.age.secrets."__arkheon-token_file".path;
|
|
|
|
url = "https://arkheon.dgnum.eu";
|
|
};
|
|
|
|
age-secrets.sources = [ ./. ];
|
|
};
|
|
}
|