49 lines
1.1 KiB
Nix
49 lines
1.1 KiB
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{ modulesPath, ... }:
|
||
|
||
{
|
||
imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
|
||
|
||
boot = {
|
||
initrd = {
|
||
availableKernelModules = [
|
||
"ata_piix"
|
||
"uhci_hcd"
|
||
"ehci_pci"
|
||
"virtio_pci"
|
||
"sr_mod"
|
||
"virtio_blk"
|
||
];
|
||
kernelModules = [ ];
|
||
|
||
luks.devices."main" = {
|
||
device = "/dev/disk/by-uuid/0092c3d6-97ce-40aa-9773-6b85fa0dfec8";
|
||
tryEmptyPassphrase = true;
|
||
};
|
||
};
|
||
|
||
kernelModules = [ "kvm-intel" ];
|
||
extraModulePackages = [ ];
|
||
};
|
||
|
||
fileSystems = {
|
||
"/" = {
|
||
device = "/dev/disk/by-uuid/f7f94fec-cdd3-4e61-b93f-18447a395018";
|
||
fsType = "ext4";
|
||
};
|
||
|
||
"/boot" = {
|
||
device = "/dev/disk/by-uuid/84F6-E7A3";
|
||
fsType = "vfat";
|
||
|
||
options = [
|
||
"fmask=0022"
|
||
"dmask=0022"
|
||
];
|
||
};
|
||
};
|
||
|
||
swapDevices = [ { device = "/dev/disk/by-uuid/d64ae21e-693c-4c77-b62c-97d5e2a960cb"; } ];
|
||
}
|