33 lines
808 B
Nix
33 lines
808 B
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{ modulesPath, ... }:
|
||
|
||
{
|
||
imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
|
||
|
||
boot = {
|
||
initrd.availableKernelModules = [
|
||
"ahci"
|
||
"ehci_pci"
|
||
"megaraid_sas"
|
||
"usb_storage"
|
||
"usbhid"
|
||
"sd_mod"
|
||
"sr_mod"
|
||
];
|
||
kernelModules = [ "kvm-intel" ];
|
||
};
|
||
|
||
fileSystems."/" = {
|
||
device = "/dev/disk/by-uuid/278cb2a2-47b9-4ec5-8b68-a5a6d037d59e";
|
||
fsType = "ext4";
|
||
};
|
||
|
||
fileSystems."/boot" = {
|
||
device = "/dev/disk/by-uuid/8BD2-C908";
|
||
fsType = "vfat";
|
||
};
|
||
|
||
swapDevices = [ { device = "/dev/disk/by-uuid/65a6f6e4-e996-4718-a4d0-cd0c78dcb15b"; } ];
|
||
}
|