Tom Hubrecht
0eb813c8bf
All checks were successful
build configuration / build_vault01 (push) Successful in 1m15s
build configuration / build_rescue01 (push) Successful in 1m15s
build configuration / build_storage01 (push) Successful in 1m18s
build configuration / build_web02 (push) Successful in 1m24s
lint / check (push) Successful in 25s
build configuration / build_web01 (push) Successful in 1m51s
build configuration / build_compute01 (push) Successful in 1m58s
build configuration / push_to_cache (push) Successful in 2m14s
34 lines
903 B
Nix
34 lines
903 B
Nix
{ pkgs, ... }:
|
|
|
|
{
|
|
services.postgresql = {
|
|
enable = true;
|
|
|
|
package = pkgs.postgresql_16;
|
|
|
|
settings = {
|
|
checkpoint_completion_target = 0.90625;
|
|
default_statistics_target = 100;
|
|
effective_cache_size = "32GB";
|
|
effective_io_concurrency = 200;
|
|
maintenance_work_mem = "2GB";
|
|
max_connections = 500;
|
|
max_parallel_maintenance_workers = 4;
|
|
max_parallel_workers = 12;
|
|
max_parallel_workers_per_gather = 4;
|
|
max_wal_size = "4GB";
|
|
max_worker_processes = 12;
|
|
min_wal_size = "1GB";
|
|
random_page_cost = 1.125;
|
|
shared_buffers = "16GB";
|
|
wal_buffers = "16MB";
|
|
work_mem = "83886kB";
|
|
};
|
|
};
|
|
|
|
dgn-console = {
|
|
# Update the versions below for upgrading
|
|
pg-upgrade-to = pkgs.postgresql_16.withPackages (ps: [ ps.postgis ]);
|
|
pg-upgrade-from = pkgs.postgresql_16.withPackages (ps: [ ps.postgis ]);
|
|
};
|
|
}
|