infrastructure/machines/compute01/librenms/default.nix
sinavir 581fa6b560
All checks were successful
build configuration / build_vault01 (push) Successful in 1m5s
build configuration / build_web02 (push) Successful in 1m6s
build configuration / build_compute01 (push) Successful in 1m11s
build configuration / build_storage01 (push) Successful in 1m10s
lint / check (push) Successful in 24s
build configuration / build_web01 (push) Successful in 1m33s
build configuration / build_rescue01 (push) Successful in 49s
chore: pre-commit hooks are supposed to be run....
2024-03-10 01:03:30 +01:00

39 lines
815 B
Nix

{ config, pkgs, ... }:
let
host = "nms.dgnum.eu";
in
{
imports = [ ./module.nix ];
services.librenms = {
enable = true;
package =
(pkgs.librenms.override { inherit (config.services.librenms) dataDir logDir; }).overrideAttrs
(old: {
patches = (old.patches or [ ]) ++ [ ./kanidm.patch ];
vendorHash = "sha256-2RgtMXQp4fTE+WloO36rtfytO4Sh2q0plt8WkWxEGHI=";
});
hostname = host;
settings = { };
database = {
createLocally = true;
passwordFile = config.age.secrets."librenms-database_password_file".path;
};
environmentFile = config.age.secrets."librenms-environment_file".path;
nginx = {
serverName = host;
enableACME = true;
forceSSL = true;
};
};
age-secrets.autoMatch = [ "librenms" ];
}