Tom Hubrecht
2f06f22ac7
All checks were successful
Check meta / check_meta (pull_request) Successful in 18s
Check meta / check_dns (pull_request) Successful in 16s
build configuration / build_and_cache_storage01 (pull_request) Successful in 1m22s
build configuration / build_and_cache_rescue01 (pull_request) Successful in 1m20s
build configuration / build_and_cache_compute01 (pull_request) Successful in 1m40s
build configuration / build_and_cache_geo01 (pull_request) Successful in 1m4s
build configuration / build_and_cache_krz01 (pull_request) Successful in 2m2s
lint / check (pull_request) Successful in 25s
build configuration / build_and_cache_geo02 (pull_request) Successful in 1m4s
build configuration / build_and_cache_web02 (pull_request) Successful in 1m16s
build configuration / build_and_cache_bridge01 (pull_request) Successful in 1m9s
build configuration / build_and_cache_vault01 (pull_request) Successful in 1m23s
build configuration / build_and_cache_web01 (pull_request) Successful in 1m54s
build configuration / build_and_cache_storage01 (push) Successful in 1m14s
build configuration / build_and_cache_compute01 (push) Successful in 1m33s
build configuration / build_and_cache_krz01 (push) Successful in 2m1s
build configuration / build_and_cache_rescue01 (push) Successful in 1m15s
build configuration / build_and_cache_geo01 (push) Successful in 1m0s
build configuration / build_and_cache_geo02 (push) Successful in 1m4s
build configuration / build_and_cache_vault01 (push) Successful in 1m21s
lint / check (push) Successful in 24s
build configuration / build_and_cache_web02 (push) Successful in 1m7s
build configuration / build_and_cache_bridge01 (push) Successful in 1m5s
build configuration / build_and_cache_web01 (push) Successful in 1m41s
58 lines
1 KiB
Nix
58 lines
1 KiB
Nix
{ config, lib, ... }:
|
|
|
|
let
|
|
host = "pads.dgnum.eu";
|
|
port = 3007;
|
|
in
|
|
{
|
|
services = {
|
|
hedgedoc = {
|
|
enable = true;
|
|
|
|
environmentFile = config.age.secrets."hedgedoc-environment_file".path;
|
|
|
|
settings = {
|
|
inherit port;
|
|
|
|
domain = host;
|
|
host = "127.0.0.1";
|
|
allowOrigin = [ host ];
|
|
|
|
protocolUseSSL = true;
|
|
|
|
allowFreeURL = true;
|
|
|
|
db = {
|
|
dialect = "postgres";
|
|
host = "/run/postgresql";
|
|
};
|
|
};
|
|
};
|
|
|
|
postgresql = {
|
|
enable = true;
|
|
|
|
ensureDatabases = [ "hedgedoc" ];
|
|
|
|
ensureUsers = [
|
|
{
|
|
name = "hedgedoc";
|
|
ensureDBOwnership = true;
|
|
}
|
|
];
|
|
};
|
|
};
|
|
|
|
dgn-web.simpleProxies.hedgedoc = {
|
|
inherit host port;
|
|
proxyWebsockets = true;
|
|
};
|
|
|
|
systemd.services.hedgedoc.serviceConfig.StateDirectory = lib.mkForce [
|
|
"hedgedoc"
|
|
"hedgedoc/uploads"
|
|
];
|
|
|
|
dgn-backups.jobs.hedgedoc.settings.paths = [ "/var/lib/hedgedoc" ];
|
|
dgn-backups.postgresDatabases = [ "hedgedoc" ];
|
|
}
|