infrastructure/patches/default.nix
Tom Hubrecht fe19171d85
All checks were successful
Check meta / check_dns (pull_request) Successful in 20s
Check meta / check_meta (pull_request) Successful in 17s
Check workflows / check_workflows (pull_request) Successful in 23s
Build all the nodes / ap01 (pull_request) Successful in 1m18s
Build all the nodes / bridge01 (pull_request) Successful in 1m54s
Build all the nodes / geo01 (pull_request) Successful in 1m55s
Build all the nodes / geo02 (pull_request) Successful in 2m0s
Build all the nodes / compute01 (pull_request) Successful in 2m19s
Build all the nodes / rescue01 (pull_request) Successful in 2m21s
Build all the nodes / storage01 (pull_request) Successful in 2m7s
Run pre-commit on all files / check (pull_request) Successful in 38s
Build all the nodes / vault01 (pull_request) Successful in 2m1s
Build all the nodes / web02 (pull_request) Successful in 1m52s
Build all the nodes / web03 (pull_request) Successful in 1m46s
Build all the nodes / web01 (pull_request) Successful in 2m37s
Build all the nodes / ap01 (push) Successful in 1m24s
Build all the nodes / bridge01 (push) Successful in 1m56s
Build all the nodes / geo02 (push) Successful in 1m56s
Build all the nodes / geo01 (push) Successful in 2m4s
Build all the nodes / rescue01 (push) Successful in 2m30s
Build all the nodes / compute01 (push) Successful in 2m31s
Run pre-commit on all files / check (push) Successful in 38s
Build all the nodes / storage01 (push) Successful in 2m1s
Build all the nodes / web02 (push) Successful in 1m55s
Build all the nodes / vault01 (push) Successful in 2m8s
Build all the nodes / web03 (push) Successful in 1m49s
Build all the nodes / web01 (push) Successful in 2m38s
feat(nextcloud): Deploy collabora without docker
2024-12-11 14:46:32 +01:00

66 lines
1.5 KiB
Nix

let
local = path: {
_type = "static";
inherit path;
};
in
{
lix = [
(local ./lix/01-disable-installChecks.patch)
];
"nixos-24.05" = [
(local ./nixpkgs/06-netbox-qrcode.patch)
# nixos/nextcloud: Rename autocreate (a no-op) to verify_bucket_exists
{
id = "275165";
hash = "sha256-9a26V3Pi8yLD3N9+mC1kvJoruxRTp/qOHapnt6VX7pw=";
}
# karla: init at 2.004
{
_type = "commit";
sha = "7c51104112e8ea0e2ac53bf7d535e677f7686a9e";
hash = "sha256-1TBLzZkvkFhCL8RYVVIUhTyrH3+X1iJIMkyHffmrOWc=";
}
# Crabfit: don't depend on all google-fonts
(local ./nixpkgs/04-crabfit-karla.patch)
# nixos/kanidm: add basic provisioning
{
id = 251598;
excludes = [ "pkgs/by-name/ka/kanidm/package.nix" ];
hash = "sha256-z4b1ljwapfj4KpXEEAMmhYKogstKtURyq+hoJcfEXiw=";
}
# kanidm-provision: 1.1.1 -> 1.1.2
{
id = 336836;
hash = "sha256-4ihpxYdLp559RIcKRC6GPt5flLCohFiPGp0k9h1s1hs=";
}
# nixos/kanidm: fix systemd service type
{
id = 337527;
excludes = [ ".git-blame-ignore-revs" ];
hash = "sha256-ca7CsPuWJqucC77ejsvoDAt+wxWLUP30IdXtZQVQrko=";
}
# Add Collabora Online
{
id = 330708;
hash = "sha256-655zkmch5VLXEUzhT6+b7QpywslDoIMZ8mY0II55Wlw=";
}
];
"nixos-unstable" = [
# netbox qrcode plugin
(local ./nixpkgs/06-netbox-qrcode.patch)
# Build netbird-relay
(local ./nixpkgs/05-netbird-relay.patch)
];
}