Tom Hubrecht
ecbad0a638
All checks were successful
Check workflows / check_workflows (push) Successful in 21s
Run pre-commit on all files / check (push) Successful in 24s
Check meta / check_dns (pull_request) Successful in 19s
Check meta / check_meta (pull_request) Successful in 18s
Check workflows / check_workflows (pull_request) Successful in 19s
Build all the nodes / bridge01 (pull_request) Successful in 1m13s
Build all the nodes / geo01 (pull_request) Successful in 1m14s
Build all the nodes / compute01 (pull_request) Successful in 1m44s
Build all the nodes / geo02 (pull_request) Successful in 1m12s
Build all the nodes / rescue01 (pull_request) Successful in 1m30s
Build all the nodes / storage01 (pull_request) Successful in 1m29s
Build all the nodes / vault01 (pull_request) Successful in 1m26s
Build all the nodes / web02 (pull_request) Successful in 1m19s
Run pre-commit on all files / check (pull_request) Successful in 24s
Build all the nodes / web01 (pull_request) Successful in 1m56s
Build all the nodes / web03 (pull_request) Successful in 1m25s
This adds subdirectories for the different types of systems, for the modules and the machines
49 lines
1,019 B
Nix
49 lines
1,019 B
Nix
{
|
|
pkgs,
|
|
sources,
|
|
config,
|
|
...
|
|
}:
|
|
|
|
let
|
|
nix-pkgs = import sources.nix-pkgs { inherit pkgs; };
|
|
in
|
|
|
|
{
|
|
services.django-apps.sites.bocal = {
|
|
source = "https://git.dgnum.eu/DGNum/www-bocal";
|
|
branch = "main";
|
|
domain = "bocal.webapps.dgnum.eu";
|
|
|
|
nginx = {
|
|
enableACME = true;
|
|
forceSSL = true;
|
|
};
|
|
|
|
webHookSecret = config.age.secrets."webhook-bocal_token".path;
|
|
|
|
python = pkgs.python3.override {
|
|
packageOverrides = _: _: { inherit (nix-pkgs) django-cas-ng django-solo loadcredential; };
|
|
};
|
|
|
|
dependencies = ps: [
|
|
ps.django
|
|
ps.django-cas-ng
|
|
ps.django-markdownx
|
|
ps.django-solo
|
|
ps.markdown
|
|
ps.pillow
|
|
ps.loadcredential
|
|
];
|
|
|
|
credentials = {
|
|
SECRET_KEY = config.age.secrets."dj_bocal-secret_key_file".path;
|
|
};
|
|
|
|
environment = {
|
|
DJANGO_SETTINGS_MODULE = "app.settings";
|
|
BOCAL_ALLOWED_HOSTS = [ "bocal.webapps.dgnum.eu" ];
|
|
BOCAL_RHOSTS_PATH = "/var/lib/django-apps/bocal/.rhosts";
|
|
};
|
|
};
|
|
}
|