492fe550d9
All checks were successful
Check meta / check_dns (pull_request) Successful in 17s
Check meta / check_meta (pull_request) Successful in 19s
build configuration / build_and_cache_rescue01 (pull_request) Successful in 1m12s
build configuration / build_and_cache_storage01 (pull_request) Successful in 1m15s
build configuration / build_and_cache_geo02 (pull_request) Successful in 1m0s
build configuration / build_and_cache_geo01 (pull_request) Successful in 1m4s
build configuration / build_and_cache_compute01 (pull_request) Successful in 1m34s
build configuration / build_and_cache_krz01 (pull_request) Successful in 2m12s
build configuration / build_and_cache_web02 (pull_request) Successful in 1m6s
build configuration / build_and_cache_web03 (pull_request) Successful in 1m7s
lint / check (pull_request) Successful in 24s
build configuration / build_and_cache_bridge01 (pull_request) Successful in 1m1s
build configuration / build_and_cache_vault01 (pull_request) Successful in 1m25s
build configuration / build_and_cache_web01 (pull_request) Successful in 1m42s
build configuration / build_and_cache_geo01 (push) Successful in 1m10s
build configuration / build_and_cache_geo02 (push) Successful in 1m14s
build configuration / build_and_cache_rescue01 (push) Successful in 1m23s
build configuration / build_and_cache_storage01 (push) Successful in 1m25s
build configuration / build_and_cache_compute01 (push) Successful in 1m38s
build configuration / build_and_cache_krz01 (push) Successful in 2m10s
lint / check (push) Successful in 24s
build configuration / build_and_cache_web03 (push) Successful in 1m9s
build configuration / build_and_cache_vault01 (push) Successful in 1m24s
build configuration / build_and_cache_web02 (push) Successful in 1m14s
build configuration / build_and_cache_bridge01 (push) Successful in 1m3s
build configuration / build_and_cache_web01 (push) Successful in 1m42s
25 lines
673 B
Nix
25 lines
673 B
Nix
{ pkgs, ... }:
|
|
{
|
|
environment.systemPackages = [
|
|
((pkgs.openai-whisper-cpp.override { cudaPackages = pkgs.cudaPackages_11; }).overrideAttrs (old: {
|
|
src = pkgs.fetchFromGitHub {
|
|
owner = "ggerganov";
|
|
repo = "whisper.cpp";
|
|
rev = "v1.7.1";
|
|
hash = "sha256-EDFUVjud79ZRCzGbOh9L9NcXfN3ikvsqkVSOME9F9oo=";
|
|
};
|
|
env = {
|
|
WHISPER_CUBLAS = "";
|
|
GGML_CUDA = "1";
|
|
};
|
|
# We only need Compute Capability 3.7.
|
|
CUDA_ARCH_FLAGS = [ "sm_37" ];
|
|
# We are GPU-only anyway.
|
|
patches = (old.patches or [ ]) ++ [
|
|
./no-weird-microarch.patch
|
|
./all-nvcc-arch.patch
|
|
];
|
|
}))
|
|
];
|
|
|
|
}
|