infrastructure/meta/nodes.nix
Tom Hubrecht 680682f520
Some checks failed
Check meta / check_meta (push) Failing after 25s
Check meta / check_dns (push) Successful in 45s
build configuration / build_vault01 (push) Successful in 3m33s
build configuration / build_storage01 (push) Successful in 3m36s
build configuration / build_compute01 (push) Successful in 3m37s
build configuration / build_web02 (push) Successful in 2m56s
lint / check (push) Successful in 24s
build configuration / build_web01 (push) Successful in 3m45s
build configuration / build_rescue01 (push) Successful in 1m29s
build configuration / push_to_cache (push) Successful in 3m24s
feat(bridge02): Initialize and add instructions to the README
2024-07-10 17:31:04 +02:00

108 lines
2 KiB
Nix

###
# File specifying all the deployement options for the nodes administrated by the dgnum.
#
# Node metadata template is:
#
# NODE_NAME = {
# adminGroups = []; # List of groups that have root access
# admins = []; # List of individuals that have root access
# deployment = {}; # Colmena deployment options
# nixpkgs = "unstable" or "22.11"; # nixpkgs version
# }
/*
Liste des différents sites :
- rat01 -> VM du NPSPI
- pav01 -> Salle serveur sous le pavillon Pasteur
- oik01 -> Local DGNum Jourdan
- hyp01 -> Salle serveur Hypnos 1
- luj01 -> VM de Luj
*/
{
bridge01 = {
site = "hyp01";
stateVersion = "24.05";
adminGroups = [ "fai" ];
deployment = {
targetHost = "fd26:baf9:d250:8000::ffff";
sshOptions = [
"-J"
"vault01.hyp01.infra.dgnum.eu"
];
};
};
web01 = {
site = "rat01";
deployment.tags = [ "web" ];
stateVersion = "23.05";
vm-cluster = "Hyperviseur NPS";
nixpkgs = "24.05";
};
compute01 = {
site = "pav01";
stateVersion = "23.05";
nix-modules = [ "services/stirling-pdf" ];
nixpkgs = "24.05";
};
geo01 = {
site = "oik01";
deployment.tags = [ "geo" ];
stateVersion = "24.05";
nixpkgs = "24.05";
};
geo02 = {
site = "oik01";
deployment.tags = [ "geo" ];
stateVersion = "24.05";
nixpkgs = "24.05";
};
storage01 = {
site = "pav01";
stateVersion = "23.11";
nixpkgs = "24.05";
nix-modules = [ "services/forgejo-nix-runners" ];
};
vault01 = {
site = "hyp01";
deployment.targetHost = "vault01.hyp01.infra.dgnum.eu";
stateVersion = "23.11";
nixpkgs = "24.05";
adminGroups = [ "fai" ];
};
web02 = {
site = "rat01";
stateVersion = "24.05";
nixpkgs = "24.05";
vm-cluster = "Hyperviseur NPS";
};
rescue01 = {
site = "luj01";
deployment.targetHost = "v6.rescue01.luj01.infra.dgnum.eu";
stateVersion = "23.11";
vm-cluster = "Hyperviseur Luj";
};
}