infrastructure/machines/nixos/web02/_configuration.nix
Tom Hubrecht 567147e9b4
All checks were successful
Build all the nodes / ap01 (push) Successful in 30s
Build all the nodes / netaccess01 (push) Successful in 19s
Build all the nodes / hypervisor03 (push) Successful in 1m9s
Build all the nodes / hypervisor02 (push) Successful in 1m11s
Build all the nodes / geo01 (push) Successful in 1m12s
Build all the nodes / geo02 (push) Successful in 1m12s
Build all the nodes / build01 (push) Successful in 1m12s
Build all the nodes / netcore00 (push) Successful in 25s
Build all the nodes / netcore01 (push) Successful in 19s
Build all the nodes / netcore02 (push) Successful in 19s
Build all the nodes / bridge01 (push) Successful in 2m3s
Build all the nodes / hypervisor01 (push) Successful in 2m1s
Build all the nodes / tower01 (push) Successful in 52s
Build all the nodes / storage01 (push) Successful in 55s
Build all the nodes / rescue01 (push) Successful in 57s
Build all the nodes / vault01 (push) Successful in 1m0s
Build all the nodes / cof02 (push) Successful in 2m30s
Build the shell / build-shell (push) Successful in 29s
Build all the nodes / web01 (push) Successful in 1m27s
Build all the nodes / compute01 (push) Successful in 3m22s
Build all the nodes / web02 (push) Successful in 1m35s
Build all the nodes / web03 (push) Successful in 1m39s
Run pre-commit on all files / pre-commit (push) Successful in 35s
fix(web02): Disable backup jobs, as it is not on the VPN
2025-04-04 10:26:25 +02:00

37 lines
690 B
Nix

# SPDX-FileCopyrightText: 2024 Tom Hubrecht <tom.hubrecht@dgnum.eu>
#
# SPDX-License-Identifier: EUPL-1.2
{ lib, pkgs, ... }:
lib.extra.mkConfig {
enabledModules = [
# List of modules to enable
"dgn-web"
];
enabledServices = [
# List of services to enable
"cas-eleves"
# "kadenios"
"django-apps"
];
extraConfig = {
# Restrict access to this node
dgn-access-control.users.root = [ "thubrecht" ];
# Disable monitoring
dgn-monitoring.enable = false;
dgn-backups.jobs = lib.mkForce { };
# Enable Postgres databases
services.postgresql = {
enable = true;
package = pkgs.postgresql_16;
};
};
root = ./.;
}