Some checks failed
Check meta / check_meta (push) Successful in 17s
Check meta / check_dns (push) Successful in 17s
Check meta / check_meta (pull_request) Successful in 18s
Check meta / check_dns (pull_request) Successful in 19s
Check workflows / check_workflows (pull_request) Successful in 21s
Build all the nodes / netcore01 (pull_request) Successful in 24s
Build all the nodes / netcore00 (pull_request) Successful in 24s
Build all the nodes / netcore02 (pull_request) Successful in 27s
Build all the nodes / netaccess01 (pull_request) Successful in 29s
Run pre-commit on all files / pre-commit (pull_request) Successful in 35s
Build the shell / build-shell (pull_request) Successful in 41s
Build all the nodes / bridge01 (pull_request) Successful in 58s
Build all the nodes / ap01 (pull_request) Successful in 59s
Build all the nodes / hypervisor01 (pull_request) Successful in 1m10s
Build all the nodes / storage01 (pull_request) Failing after 1m10s
Build all the nodes / hypervisor03 (pull_request) Successful in 1m12s
Build all the nodes / build01 (pull_request) Successful in 1m25s
Build all the nodes / hypervisor02 (pull_request) Successful in 1m26s
Build all the nodes / geo02 (pull_request) Successful in 1m31s
Build all the nodes / geo01 (pull_request) Successful in 1m33s
Build all the nodes / tower01 (pull_request) Successful in 1m35s
Build all the nodes / web02 (pull_request) Successful in 1m40s
Build all the nodes / cof02 (pull_request) Successful in 1m42s
Build all the nodes / web03 (pull_request) Successful in 1m41s
Build all the nodes / rescue01 (pull_request) Successful in 1m44s
Build all the nodes / compute01 (pull_request) Successful in 1m45s
Build all the nodes / web01 (pull_request) Successful in 1m48s
Build all the nodes / netcore02 (push) Successful in 23s
Build all the nodes / netcore00 (push) Successful in 25s
Build all the nodes / netaccess01 (push) Successful in 26s
Build all the nodes / netcore01 (push) Successful in 26s
Build the shell / build-shell (push) Successful in 30s
Run pre-commit on all files / pre-commit (push) Successful in 35s
Build all the nodes / ap01 (push) Successful in 39s
Build all the nodes / vault01 (pull_request) Failing after 2m25s
Build all the nodes / storage01 (push) Failing after 1m1s
Build all the nodes / bridge01 (push) Successful in 1m8s
Build all the nodes / geo02 (push) Successful in 1m14s
Build all the nodes / geo01 (push) Successful in 1m15s
Build all the nodes / hypervisor01 (push) Successful in 1m15s
Build all the nodes / hypervisor02 (push) Successful in 1m17s
Build all the nodes / build01 (push) Successful in 1m18s
Build all the nodes / tower01 (push) Successful in 1m20s
Build all the nodes / web02 (push) Successful in 1m20s
Build all the nodes / rescue01 (push) Successful in 1m22s
Build all the nodes / web03 (push) Successful in 1m24s
Build all the nodes / hypervisor03 (push) Successful in 1m36s
Build all the nodes / cof02 (push) Successful in 1m43s
Build all the nodes / web01 (push) Successful in 1m44s
Build all the nodes / vault01 (push) Failing after 2m14s
Build all the nodes / compute01 (push) Successful in 2m20s
We have build01 now
36 lines
588 B
Nix
36 lines
588 B
Nix
# SPDX-FileCopyrightText: 2024 Tom Hubrecht <tom.hubrecht@dgnum.eu>
|
|
#
|
|
# SPDX-License-Identifier: EUPL-1.2
|
|
|
|
{ lib, ... }:
|
|
|
|
lib.extra.mkConfig {
|
|
enabledModules = [
|
|
# List of modules to enable
|
|
"dgn-backups"
|
|
"dgn-web"
|
|
];
|
|
|
|
enabledServices = [
|
|
# List of services to enable
|
|
"tvix-cache"
|
|
"forgejo"
|
|
"forgejo-runners"
|
|
"garage"
|
|
"influxdb"
|
|
"netbird"
|
|
"openbao"
|
|
"peertube"
|
|
"redirections"
|
|
"victorialogs"
|
|
"victoriametrics"
|
|
];
|
|
|
|
extraConfig = {
|
|
dgn-hardware.useZfs = true;
|
|
|
|
services.netbird.enable = true;
|
|
};
|
|
|
|
root = ./.;
|
|
}
|