infrastructure/machines/nixos/compute01/_configuration.nix
Tom Hubrecht 41a4b98cc5
Some checks failed
Check meta / check_meta (pull_request) Successful in 15s
Check workflows / check_workflows (pull_request) Successful in 17s
Build all the nodes / netaccess01 (pull_request) Successful in 22s
Build all the nodes / netcore00 (pull_request) Successful in 21s
Check meta / check_dns (pull_request) Successful in 34s
Build all the nodes / ap01 (pull_request) Successful in 35s
Build all the nodes / netcore01 (pull_request) Successful in 20s
Build all the nodes / netcore02 (pull_request) Successful in 21s
Build all the nodes / hypervisor02 (pull_request) Successful in 1m4s
Build all the nodes / bridge01 (pull_request) Successful in 1m5s
Build all the nodes / compute01 (pull_request) Failing after 1m6s
Build all the nodes / geo01 (pull_request) Successful in 1m7s
Build all the nodes / build01 (pull_request) Successful in 1m9s
Build all the nodes / hypervisor01 (pull_request) Successful in 1m10s
Build all the nodes / rescue01 (pull_request) Successful in 1m4s
Build the shell / build-shell (pull_request) Successful in 27s
Build all the nodes / vault01 (pull_request) Successful in 1m10s
Build all the nodes / web02 (pull_request) Successful in 1m9s
Run pre-commit on all files / pre-commit (pull_request) Successful in 45s
Build all the nodes / geo02 (pull_request) Successful in 1m55s
Build all the nodes / hypervisor03 (pull_request) Successful in 1m55s
Build all the nodes / cof02 (pull_request) Successful in 2m0s
Build all the nodes / tower01 (pull_request) Successful in 1m36s
Build all the nodes / web01 (pull_request) Successful in 1m35s
Build all the nodes / web03 (pull_request) Successful in 1m8s
Check meta / check_dns (push) Successful in 17s
Check meta / check_meta (push) Successful in 16s
Build all the nodes / netcore02 (push) Successful in 21s
Build all the nodes / netaccess01 (push) Successful in 21s
Build all the nodes / compute01 (push) Failing after 30s
Build all the nodes / ap01 (push) Successful in 34s
Build all the nodes / netcore00 (push) Successful in 37s
Build all the nodes / netcore01 (push) Successful in 38s
Build the shell / build-shell (push) Successful in 23s
Build all the nodes / hypervisor03 (push) Successful in 1m4s
Run pre-commit on all files / pre-commit (push) Successful in 31s
Build all the nodes / build01 (push) Successful in 1m7s
Build all the nodes / bridge01 (push) Successful in 1m9s
Build all the nodes / tower01 (push) Successful in 1m9s
Build all the nodes / rescue01 (push) Successful in 1m11s
Build all the nodes / cof02 (push) Successful in 1m13s
Build all the nodes / storage01 (push) Failing after 1m11s
Build all the nodes / web02 (push) Successful in 1m0s
Build all the nodes / web03 (push) Successful in 1m5s
Build all the nodes / web01 (push) Successful in 1m37s
Build all the nodes / hypervisor02 (push) Successful in 1m52s
Build all the nodes / geo01 (push) Successful in 1m53s
Build all the nodes / geo02 (push) Successful in 1m53s
Build all the nodes / hypervisor01 (push) Successful in 1m52s
Build all the nodes / vault01 (push) Failing after 2m3s
Build all the nodes / storage01 (pull_request) Failing after 1m4s
feat(compute01): Deploy docuseal on docuseal.dgnum.eu
2025-04-14 11:24:10 +02:00

55 lines
949 B
Nix

# SPDX-FileCopyrightText: 2024 Tom Hubrecht <tom.hubrecht@dgnum.eu>
#
# SPDX-License-Identifier: EUPL-1.2
{ lib, ... }:
lib.extra.mkConfig {
# List of modules to enable
enabledModules = [
# INFO: This list needs to stay sorted alphabetically
"dgn-backups"
"dgn-chatops"
"dgn-web"
];
# List of services to enable
enabledServices = [
# INFO: This list needs to stay sorted alphabetically
"arkheon"
"dgsi"
"docuseal"
"ds-fr"
"extranix"
"grafana"
"hedgedoc"
"kanidm"
"librenms"
"mastodon"
# "netbox"
"nextcloud"
"ollama-proxy"
"outline"
"plausible"
"postgresql"
"pretalx"
"pretix"
"rstudio-server"
# "satosa"
"signal-irc-bridge"
"signald"
"stirling-pdf"
"takumi"
"telegraf"
"vaultwarden"
"zammad"
];
extraConfig = {
dgn-hardware.useZfs = true;
services.netbird.enable = true;
};
root = ./.;
}