infrastructure/machines/compute01/satosa/package/satosa.nix
Tom Hubrecht 84e5f4a33a
All checks were successful
build configuration / build_vault01 (push) Successful in 1m5s
build configuration / build_rescue01 (push) Successful in 1m6s
build configuration / build_web02 (push) Successful in 1m7s
build configuration / build_storage01 (push) Successful in 1m8s
lint / check (push) Successful in 23s
build configuration / build_compute01 (push) Successful in 1m35s
build configuration / build_web01 (push) Successful in 1m36s
fix(satosa): Use GH source
2024-04-08 23:23:25 +02:00

52 lines
1,008 B
Nix

{
lib,
python3,
fetchFromGitHub,
cookies-samesite-compat,
pyop,
}:
python3.pkgs.buildPythonPackage rec {
pname = "satosa";
version = "8.4.0";
pyproject = true;
src = fetchFromGitHub {
owner = "IdentityPython";
repo = "SATOSA";
rev = "v${version}";
hash = "sha256-q7XmZ3EnAFO1OXIhXIF4Vd0H8uaayFIHFZpWiZUsAFA=";
};
propagatedBuildInputs = with python3.pkgs; [
chevron
click
cookies-samesite-compat
gunicorn
importlib-metadata
pycryptodomex
pyop
pysaml2
pyyaml
requests
werkzeug
];
passthru.optional-dependencies = with python3.pkgs; {
ldap = [ ldap3 ];
pyop_mongo = [ pyop ];
pyop_redis = [ pyop ];
};
passthru.python = python3;
pythonImportsCheck = [ "satosa" ];
meta = with lib; {
description = "Protocol proxy (SAML/OIDC)";
homepage = "https://pypi.org/project/SATOSA";
license = licenses.asl20;
maintainers = with maintainers; [ thubrecht ];
mainProgram = "satosa";
};
}