Julien Malka
407f99ca95
All checks were successful
Check meta / check_dns (pull_request) Successful in 17s
Check meta / check_meta (pull_request) Successful in 17s
lint / check (push) Successful in 23s
build configuration / build_and_cache_storage01 (pull_request) Successful in 1m11s
build configuration / build_and_cache_rescue01 (pull_request) Successful in 1m12s
build configuration / build_and_cache_compute01 (pull_request) Successful in 1m40s
build configuration / build_and_cache_krz01 (pull_request) Successful in 2m3s
build configuration / build_and_cache_geo01 (pull_request) Successful in 1m4s
build configuration / build_and_cache_geo02 (pull_request) Successful in 1m1s
build configuration / build_and_cache_vault01 (pull_request) Successful in 1m19s
lint / check (pull_request) Successful in 24s
build configuration / build_and_cache_bridge01 (pull_request) Successful in 1m2s
build configuration / build_and_cache_web01 (pull_request) Successful in 1m44s
build configuration / build_and_cache_web02 (pull_request) Successful in 1m16s
47 lines
780 B
Nix
47 lines
780 B
Nix
{ lib, ... }:
|
|
|
|
lib.extra.mkConfig {
|
|
# List of modules to enable
|
|
enabledModules = [
|
|
# INFO: This list needs to stay sorted alphabetically
|
|
"dgn-backups"
|
|
"dgn-chatops"
|
|
"dgn-web"
|
|
];
|
|
|
|
# List of services to enable
|
|
enabledServices = [
|
|
# INFO: This list needs to stay sorted alphabetically
|
|
"arkheon"
|
|
"dgsi"
|
|
"ds-fr"
|
|
"grafana"
|
|
"hedgedoc"
|
|
"kanidm"
|
|
"librenms"
|
|
"mastodon"
|
|
"nextcloud"
|
|
"ollama-proxy"
|
|
"outline"
|
|
"pages"
|
|
"plausible"
|
|
"postgresql"
|
|
"rstudio-server"
|
|
"satosa"
|
|
"signal-irc-bridge"
|
|
"signald"
|
|
"stirling-pdf"
|
|
"takumi"
|
|
"telegraf"
|
|
"vaultwarden"
|
|
"zammad"
|
|
];
|
|
|
|
extraConfig = {
|
|
dgn-hardware.useZfs = true;
|
|
|
|
services.netbird.enable = true;
|
|
};
|
|
|
|
root = ./.;
|
|
}
|