Tom Hubrecht
88d9b8c3e3
Some checks failed
Check meta / check_dns (pull_request) Successful in 19s
Check meta / check_meta (pull_request) Successful in 20s
Check workflows / check_workflows (pull_request) Successful in 24s
Build all the nodes / ap01 (pull_request) Successful in 1m15s
Build all the nodes / bridge01 (pull_request) Successful in 1m53s
Build all the nodes / geo01 (pull_request) Successful in 1m55s
Build all the nodes / geo02 (pull_request) Successful in 1m53s
Build all the nodes / compute01 (pull_request) Successful in 2m33s
Build all the nodes / rescue01 (pull_request) Successful in 2m13s
Build all the nodes / storage01 (pull_request) Successful in 1m57s
Run pre-commit on all files / check (pull_request) Successful in 30s
Build all the nodes / web02 (pull_request) Successful in 1m47s
Build all the nodes / vault01 (pull_request) Successful in 2m21s
Build all the nodes / web03 (pull_request) Successful in 1m40s
Build all the nodes / web01 (pull_request) Successful in 2m54s
Check meta / check_dns (push) Successful in 20s
Check meta / check_meta (push) Successful in 19s
Check workflows / check_workflows (push) Successful in 25s
Build all the nodes / ap01 (push) Successful in 1m16s
Build all the nodes / bridge01 (push) Successful in 1m41s
Build all the nodes / geo02 (push) Successful in 1m44s
Build all the nodes / geo01 (push) Successful in 1m53s
Build all the nodes / compute01 (push) Successful in 2m20s
Build all the nodes / rescue01 (push) Successful in 1m49s
Build all the nodes / storage01 (push) Successful in 1m46s
Build all the nodes / vault01 (push) Successful in 1m45s
Run pre-commit on all files / check (push) Successful in 30s
Build all the nodes / web02 (push) Has been cancelled
Build all the nodes / web01 (push) Has been cancelled
Build all the nodes / web03 (push) Has been cancelled
Signed-off-by: Tom Hubrecht <tom.hubrecht@dgnum.eu> Acked-by: Ryan Lahfa <ryan.lahfa@dgnum.eu> Acked-by: Maurice Debray <maurice.debray@dgnum.eu> Acked-by: Lubin Bailly <lubin.bailly@dgnum.eu> Acked-by: Jean-Marc Gailis <jean-marc.gailis@dgnum.eu> as the legal authority, at the time of writing, in DGNum. Acked-by: Elias Coppens <elias.coppens@dgnum.eu> as a member, at the time of writing, of the DGNum executive counsel.
84 lines
1.7 KiB
Nix
84 lines
1.7 KiB
Nix
# SPDX-FileCopyrightText: 2024 Lubin Bailly <lubin.bailly@dgnum.eu>
|
|
# SPDX-FileCopyrightText: 2024 Tom Hubrecht <tom.hubrecht@dgnum.eu>
|
|
#
|
|
# SPDX-License-Identifier: EUPL-1.2
|
|
|
|
_:
|
|
|
|
{
|
|
networking = {
|
|
useNetworkd = true;
|
|
useDHCP = false;
|
|
|
|
nftables.enable = true;
|
|
firewall.allowedUDPPorts = [ 67 ];
|
|
};
|
|
|
|
systemd.network = {
|
|
networks = {
|
|
"10-eno1" = {
|
|
name = "eno1";
|
|
networkConfig = {
|
|
VLAN = [
|
|
"vlan-admin"
|
|
"vlan-uplink-oob"
|
|
];
|
|
|
|
LinkLocalAddressing = false;
|
|
LLDP = false;
|
|
EmitLLDP = false;
|
|
IPv6AcceptRA = false;
|
|
IPv6SendRA = false;
|
|
};
|
|
# address = [ "192.168.222.1/24" ];
|
|
};
|
|
|
|
"10-vlan-admin" = {
|
|
name = "vlan-admin";
|
|
# DHCP for the BMC
|
|
networkConfig.DHCPServer = "yes";
|
|
|
|
dhcpServerConfig = {
|
|
PoolOffset = 128;
|
|
EmitDNS = false;
|
|
EmitNTP = false;
|
|
EmitSIP = false;
|
|
EmitPOP3 = false;
|
|
EmitSMTP = false;
|
|
EmitLPR = false;
|
|
UplinkInterface = ":none";
|
|
};
|
|
|
|
address = [
|
|
"fd26:baf9:d250:8000::ffff/64"
|
|
"192.168.222.1/24"
|
|
];
|
|
};
|
|
|
|
"10-vlan-uplink-oob" = {
|
|
name = "vlan-uplink-oob";
|
|
networkConfig.DHCP = "ipv4";
|
|
};
|
|
};
|
|
|
|
netdevs = {
|
|
"10-vlan-admin" = {
|
|
netdevConfig = {
|
|
Name = "vlan-admin";
|
|
Kind = "vlan";
|
|
};
|
|
|
|
vlanConfig.Id = 3000;
|
|
};
|
|
|
|
"10-vlan-uplink-oob" = {
|
|
netdevConfig = {
|
|
Name = "vlan-uplink-oob";
|
|
Kind = "vlan";
|
|
};
|
|
|
|
vlanConfig.Id = 500;
|
|
};
|
|
};
|
|
};
|
|
}
|