infrastructure/machines/nixos/compute01/telegraf.nix
Tom Hubrecht ecbad0a638
All checks were successful
Check workflows / check_workflows (push) Successful in 21s
Run pre-commit on all files / check (push) Successful in 24s
Check meta / check_dns (pull_request) Successful in 19s
Check meta / check_meta (pull_request) Successful in 18s
Check workflows / check_workflows (pull_request) Successful in 19s
Build all the nodes / bridge01 (pull_request) Successful in 1m13s
Build all the nodes / geo01 (pull_request) Successful in 1m14s
Build all the nodes / compute01 (pull_request) Successful in 1m44s
Build all the nodes / geo02 (pull_request) Successful in 1m12s
Build all the nodes / rescue01 (pull_request) Successful in 1m30s
Build all the nodes / storage01 (pull_request) Successful in 1m29s
Build all the nodes / vault01 (pull_request) Successful in 1m26s
Build all the nodes / web02 (pull_request) Successful in 1m19s
Run pre-commit on all files / check (pull_request) Successful in 24s
Build all the nodes / web01 (pull_request) Successful in 1m56s
Build all the nodes / web03 (pull_request) Successful in 1m25s
chore: Abstract machines and modules
This adds subdirectories for the different types of systems, for the
modules and the machines
2024-12-08 13:39:10 +01:00

43 lines
885 B
Nix

{ config, ... }:
{
services.telegraf = {
enable = true;
extraConfig = {
agent = {
interval = "10s";
round_interval = true;
metric_batch_size = 1000;
metric_buffer_limit = 10000;
collection_jitter = "0s";
};
inputs = {
diskio = {
device_tags = [
"ID_FS_TYPE"
"ID_FS_USAGE"
];
name_templates = [
"$ID_FS_LABEL"
"$DM_VG_NAME/$DM_LV_NAME"
];
};
};
outputs = {
influxdb_v2 = {
urls = [ "https://influx.dgnum.eu" ];
token = "$TELEGRAF_INFLUXDB_TOKEN";
organization = "dgnum";
bucket = "telegraf";
};
};
};
environmentFiles = [ config.age.secrets."telegraf-environment_file".path ];
};
age-secrets.autoMatch = [ "telegraf" ];
}