infrastructure/workflows/eval-shell.nix
sinavir 6a3511cc71
All checks were successful
Check meta / check_dns (pull_request) Successful in 28s
Check meta / check_meta (pull_request) Successful in 28s
Check workflows / check_workflows (pull_request) Successful in 27s
Run pre-commit on all files / pre-commit (push) Successful in 44s
Build all the nodes / ap01 (pull_request) Successful in 1m11s
Build all the nodes / bridge01 (pull_request) Successful in 1m54s
Build all the nodes / geo01 (pull_request) Successful in 2m6s
Build all the nodes / geo02 (pull_request) Successful in 2m7s
Build all the nodes / hypervisor01 (pull_request) Successful in 2m3s
Build all the nodes / compute01 (pull_request) Successful in 2m34s
Build all the nodes / hypervisor02 (pull_request) Successful in 1m49s
Build all the nodes / netcore02 (pull_request) Successful in 32s
Build all the nodes / hypervisor03 (pull_request) Successful in 1m50s
Build all the nodes / rescue01 (pull_request) Successful in 2m1s
Build all the nodes / vault01 (pull_request) Successful in 2m3s
Build all the nodes / storage01 (pull_request) Successful in 2m24s
Build the shell / build-shell (pull_request) Successful in 43s
Build all the nodes / web02 (pull_request) Successful in 2m13s
Run pre-commit on all files / pre-commit (pull_request) Successful in 37s
Build all the nodes / web03 (pull_request) Successful in 2m5s
Build all the nodes / web01 (pull_request) Successful in 3m0s
fix(scripts): Refactor cache uploading
2024-12-22 22:28:55 +01:00

29 lines
709 B
Nix

# SPDX-FileCopyrightText: 2024 Tom Hubrecht <tom.hubrecht@dgnum.eu>
#
# SPDX-License-Identifier: EUPL-1.2
{
name = "Build the shell";
on = {
pull_request.branches = [ "main" ];
push.branches = [ "main" ];
};
jobs = {
build-shell = {
runs-on = "nix";
steps = [
{ uses = "actions/checkout@v3"; }
{
name = "Build and cache shell";
run = ''nix-shell -A eval-shell --run "nix-build-and-cache -A devShell"'';
env = {
STORE_ENDPOINT = "https://tvix-store.dgnum.eu/infra-signing/";
STORE_USER = "admin";
STORE_PASSWORD = "\${{ secrets.STORE_PASSWORD }}";
};
}
];
};
};
}