dgnum.eu/site/default.nix
Tom Hubrecht c665ce2eb6 Add deployment workflow (#7)
Reviewed-on: https://git.hubrecht.ovh/DGNum/dgnum.eu/pulls/7
Co-authored-by: Tom Hubrecht <tom@hubrecht.ovh>
Co-committed-by: Tom Hubrecht <tom@hubrecht.ovh>
2023-06-30 09:56:50 +00:00

20 lines
333 B
Nix

{ glibcLocales
, nix-gitignore
, ssg
, stdenv
}:
stdenv.mkDerivation {
name = "dgnum.eu";
version = "0.1.0";
srcs = nix-gitignore.gitignoreSourcePure ../.gitignore ./.;
buildInputs = [ glibcLocales ];
LANG = "en_US.UTF-8";
buildPhase = ''
${ssg}/bin/ssg build
'';
installPhase = ''
cp -av _site $out
'';
}