24 lines
459 B
Nix
24 lines
459 B
Nix
{ lib, config, ... }:
|
|
let
|
|
inherit (lib)
|
|
mkOption
|
|
;
|
|
inherit (lib.types)
|
|
listOf
|
|
str
|
|
;
|
|
in
|
|
{
|
|
options = {
|
|
protocols.rstp = mkOption {
|
|
type = listOf str;
|
|
description = ''
|
|
List of interfaces on which Rapid Spanning Tree Protocol should be enabled.
|
|
'';
|
|
};
|
|
};
|
|
config.netconf.xml.protocols.rstp = {
|
|
"@operation" = "replace";
|
|
interface = map (name: { inherit name; }) config.protocols.rstp;
|
|
};
|
|
}
|