Netconf-Module/ex4400-em-4Y.nix

17 lines
298 B
Nix

{ lib, ... }:
let
full = [
"2/0"
"2/1"
"2/2"
"2/3"
];
in
{
netconf.mandatoryInterfaces = lib.listToAttrs (
map (name: {
inherit name;
value.supportPoE = false;
}) (map (i: "ge-0/" + i) full ++ map (i: "xe-0/" + i) full ++ map (i: "et-0/" + i) full)
);
}