46 lines
775 B
Nix
46 lines
775 B
Nix
{
|
|
lib,
|
|
modulesPath,
|
|
...
|
|
}:
|
|
|
|
{
|
|
imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
|
|
|
|
boot = {
|
|
initrd = {
|
|
availableKernelModules = [
|
|
"ahci"
|
|
"xhci_pci"
|
|
"virtio_pci"
|
|
"sr_mod"
|
|
"virtio_blk"
|
|
];
|
|
kernelModules = [ ];
|
|
};
|
|
kernelModules = [ "kvm-intel" ];
|
|
extraModulePackages = [ ];
|
|
};
|
|
|
|
fileSystems = {
|
|
"/" = {
|
|
device = "UUID=301a23cf-1aa3-4c53-a174-1a97592da5fa";
|
|
fsType = "bcachefs";
|
|
options = [
|
|
"fsck"
|
|
"fix_errors"
|
|
];
|
|
};
|
|
|
|
"/boot" = {
|
|
device = "/dev/disk/by-uuid/F594-E8DB";
|
|
fsType = "vfat";
|
|
};
|
|
};
|
|
|
|
swapDevices = [ ];
|
|
|
|
networking.useDHCP = lib.mkDefault true;
|
|
|
|
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
|
|
}
|